Is my device compatible with WHOOP Strap 3.0?

The Whoop 3.0 Strap is compatible with both Android and iOS platforms that meet it's Bluetooth Low Energy (BLE) requirements. This means it requires phones that have Bluetooth Low Energy version 4.2 with Data Length Extension enabled or higher.

It is important to note that the WHOOP Strap can only be connected to one device at a time unless you are connecting to another supported device (Fenix 5, Peleton, etc.) using the Heart Rate Broadcast feature. We do not recommend continuously switch between different devices for daily use outside of that.

Was this article helpful?
0 out of 2 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.