Note: the following troubleshooting steps are best performed when instructed to do so by Membership Services. If you are currently running in an issue, please reach out to us! 

    1. Step 1: Plug the battery pack into the charger and ensure a red or green LED turns on. If no LEDs illuminate on the battery pack, ensure the orientation is correct as outlined in the attached image. Additionally, if no battery pack LEDs illuminate, try a different charger, cable, or power outlet.
      mceclip0.png
      • If neither the red  OR green LED appears on the battery pack, please send Membership Services a photo of the battery pack with the USB charging cable attached and plugged into either a USB port or wall adapter (making sure all three items are visible in the image).
  1. Ensure the Strap is off-wrist and the metal clasp is snapped closed, and slide the battery pack onto the Strap (note: the battery pack should still be plugged into the charging cable and have an LED on).
  2. Wait 5-10 minutes.
  3. Now, with the battery pack & Strap pair still attached to the charger, place your thumb on the bottom of the Strap sensor (the area inside the red oval on the underside of the Strap) for 15 seconds. Remove your thumb from the sensor. Do the Green LEDs appear on the bottom of the sensor? If they do not illuminate and you are able to do so, please take a quick video to help us see what’s going on.
Was this article helpful?
4 out of 24 found this helpful

Comments

0 comments

Article is closed for comments.