Skip to main content
Whoop

WHOOP App Minimum Software Requirements

The WHOOP app can be installed on an Android or iOS device. To set up and use WHOOP products and services, you must install the WHOOP app on a compatible device running at least Bluetooth version 4.2 on one of the following operating systems:

Note: Users on beta versions of iOS or Android are likely to experience compatibility issues.

It is recommended that you keep the WHOOP app running at all times in the background. This allows data from your WHOOP to continuously sync with the app, ensuring your scores and recommendations are up-to-date. If you close the app, it will need to sync all of the data from your WHOOP the next time you open the app. This will take some time, as the data needs to catch up.

Be sure to update your iOS/Android device to the most recent OS version for the latest features in the WHOOP app. If your device is not running a supported OS, you may be able to use the WHOOP app, but you will not be able to reinstall it if you delete it. 

We strongly advise against syncing WHOOP to several devices, such as switching between a tablet and a mobile phone, as this will likely lead to Bluetooth connectivity and data syncing issues.

Apple iOS 14 or higher

  • iPhone 6s or higher

Android OS 10.0 or higher 

Android devices must natively support the Google Play Store.

Note: OnePlus and Sony devices running Android 13 may experience connectivity issues that significantly limit the use of the WHOOP app. Please reach out to your device manufacturer's support if you encounter connectivity issues.

Devices from the following manufacturers are known to cause device connectivity and app performance issues when running Android 9 or lower:

  • Huawei
  • LG
  • OnePlus: The battery optimization feature specifically causes compatibility issues
  • Sony
  • Xiaomi
  • Meizu
  • Blackberry
  • Motorola
  • Oppo
  • SHIFT

As these devices may not support connection to or use of the WHOOP app when running OS 9 and below, we strongly recommend updating to OS 10 or above.

  • Was this article helpful?